MacでMAMPのPHP7をコンソールから使うようにするには

私のMacのPHP環境が5系でした。

$ php -v
PHP 5.6.24 (cli) (built: Aug 8 2016 16:58:37)
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies

これをMAMPの7系のPHPを使うように設定していきます

まずは確認です。7系がない場合はMAMPを最新に変更しましょう。
$ ls /Applications/MAMP/bin/php

browscap.ini php5.4.45 php5.5.38 php5.6.25 php7.0.10

7系があったので、次にすすみます。
$ vi ~/.bash_profile
これで下記の1行を追加します。
export PATH=/Applications/MAMP/bin/php/php7.0.10/bin:$PATH

そして、設定を反映させます。
source ~/.bash_profile

確認します。
php -v
PHP 7.0.10 (cli) (built: Aug 25 2016 17:32:10) ( NTS )
Copyright (c) 1997-2016 The PHP Group

無事7系に変更されていました。


コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

*

WP-SpamFree by Pole Position Marketing